CompletedPlanned Maintenance
Status
Resolved after 39 minutes
Started
July 8, 2022 at 4:00 AM
Completed
July 8, 2022 at 4:39 AM
Affects
Deliveries API
Mobile App
Web App
- CompletedJuly 8, 2022 at 4:38 AM
- In progressJuly 8, 2022 at 4:13 AM
- PlannedJuly 8, 2022 at 4:00 AM