All systems operational

Show current status

[Resolved] We are experiencing slower response times

Started on November 25, 2020 at 4:24 PM. Resolved after less than a minute

Affected

Web App
Mobile App
Deliveries API
  • Resolved
    November 25, 2020 at 4:24 PM  –  

    We have identified the cause of the issue and are working on a fix.