Show current status

[Resolved] Driver earnings showing up wrong.

Started on December 18, 2020 at 9:41 PM. Resolved after 14 minutes

Affected

Web App
Mobile App
  • Investigating
    December 18, 2020 at 9:41 PM  –  

    Drivers are unable to see their earnings Payouts of earnings are being delayed

  • Monitoring
    December 18, 2020 at 9:50 PM  –  

    Our earning processor is experiencing issues. We are monitoring.

  • Resolved
    December 18, 2020 at 9:55 PM  –  

    The issue has been resolved.